Welcome, Guest
Username: Password: Remember me
NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC:

Support Request - File Integrity Issue 1 year 10 months ago #45054

  • joelkarp
  • joelkarp's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
JohnM's response - "Looks like a major clock rate mismatch to me,. Something in the system is operating at a different sample rate, e.g. 44.1k vs 48k."

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45066

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3775
  • Thank you received: 1588
Could you post your files to Dropbox (or other file-sharing service)?
  • Stimulus file
  • Recorded sweep that produces the expected impulse response
  • Recorded sweep that produces the weird impulse response
I am not miniDSP support.

"You must ask the right questions." - Dr. Alfred Lanning's hologram.
-> Have you read the User Manual??
-> Have you drawn and posted a diagram?
-> Have you posted a screenshot?
-> Have you posted your config file?

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45068

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14

Anyway, here's another plot. The "impulse response" at the left is from a 256k sweep, at the right is from a 2M sweep. If these were real, the length of the impulse response wouldn't vary with the sweep length. (Ergo, in case it's not obvious to everybody, they aren't real.)



I suppose something JohnM might want to look into. Why it happens with Volumio on the SHD only, I have no idea. It doesn't happen with Volumio on an RPi. I'm guessing maybe clock drift of some kind?

Looks like about 500ppm of clock rate difference to me.

Attachments:

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45073

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3775
  • Thank you received: 1588
Hah! I did not know you could do that. It's 1207 ppm but my recordings are at 96 kHz.

John, am I correct in thinking that Import Sweep Recordings normally does an automatic clock rate adjustment? The reason being that the recording I made via Volumio on an RPi has about 2200 ppm difference, yet the impulse response looks fine.
I am not miniDSP support.

"You must ask the right questions." - Dr. Alfred Lanning's hologram.
-> Have you read the User Manual??
-> Have you drawn and posted a diagram?
-> Have you posted a screenshot?
-> Have you posted your config file?

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45074

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14

John, am I correct in thinking that Import Sweep Recordings normally does an automatic clock rate adjustment? The reason being that the recording I made via Volumio on an RPi has about 2200 ppm difference, yet the impulse response looks fine.

Only if the Analysis preference option to "Adjust clock with acoustic ref" is selected. The measurement info panel will show the clock adjustment that has been applied, if any. Ordinarily clock differences should be well below 50 ppm, large differences are a sign something is wrong.

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45075

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14

I've discovered that you can induce the weird impulse response just by stretching and padding the stimulus and using that in lieu of a recorded sweep. I've given up on it now tho due to null pointer errors in the import.

Which REW version were you using? Do you have the detailed error info?

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45077

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3775
  • Thank you received: 1588

I've discovered that you can induce the weird impulse response just by stretching and padding the stimulus and using that in lieu of a recorded sweep. I've given up on it now tho due to null pointer errors in the import.

Which REW version were you using? Do you have the detailed error info?


I've been trying to figure out the pattern. It turns out that this error occurs when REW is doing the clock rate adjustment:



The error messages and details (the log file shows the same):



This occurs only when Preferences -> Analysis -> Adjust clock with acoustic ref is turned on. The other settings don't seem to make any difference. I get the same error on Mac or Windows. Here are two files that consistently throw the error (for me). Stimulus:

www.dropbox.com/s/5xkrp06pgf7kspb/256kMe...CM24_L_refL.wav?dl=0

Recording:

www.dropbox.com/s/533xv3xnfv7rzng/LL96k.wav?dl=0

(That's a 16-bit file but 24 bits didn't seem to make a difference.)
I am not miniDSP support.

"You must ask the right questions." - Dr. Alfred Lanning's hologram.
-> Have you read the User Manual??
-> Have you drawn and posted a diagram?
-> Have you posted a screenshot?
-> Have you posted your config file?
Attachments:
The following user(s) said Thank You: JohnPM

Please Log in or Create an account to join the conversation.

Last edit: by john.reekie.

Support Request - File Integrity Issue 1 year 10 months ago #45078

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14
Thanks John, I've fixed that for the next build. REW estimates 1205.5 ppm clock rate error on that file.
The following user(s) said Thank You: entripy

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45080

  • joelkarp
  • joelkarp's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Very interesting!

What conclusions - if any - can be drawn from this data?

@john.reekie - would you still like me to post my sweeps or have we since moved passed that request?

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45081

  • joelkarp
  • joelkarp's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
...What I meant to ask was what conclusions re: the SHD / Volumio can we draw from this data.

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45082

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14

would you still like me to post my sweeps or have we since moved passed that request?

I'd like to see them.

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45083

  • joelkarp
  • joelkarp's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Sure. This is the EXACT file on the USB drive that is causing this. It is also the same file that was imported into Roon that was streamed from both my Chromecast and via Volumio: drive.google.com/open?id=1ENZkyUAP5UoI7LD8JIXjGJbKMpcPwLt6

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45084

  • JohnPM
  • JohnPM's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 39
  • Thank you received: 14
Can't do much with the sweep file on its own, need the files that were captured as well. I also notice it is from an older REW version so there may be a limited amount I can do with the results.

Please Log in or Create an account to join the conversation.

Support Request - File Integrity Issue 1 year 10 months ago #45085

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3775
  • Thank you received: 1588
[Cross-posted with JohnPM]

Could you also upload the recordings?
  • Stimulus file - OK got this
  • Recorded sweep that produces the expected impulse response
  • Recorded sweep that produces the weird impulse response

BTW what version of REW are you running?
I am not miniDSP support.

"You must ask the right questions." - Dr. Alfred Lanning's hologram.
-> Have you read the User Manual??
-> Have you drawn and posted a diagram?
-> Have you posted a screenshot?
-> Have you posted your config file?

Please Log in or Create an account to join the conversation.

Last edit: by john.reekie.

Support Request - File Integrity Issue 1 year 10 months ago #45086

  • joelkarp
  • joelkarp's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 0
Ahhhh... I get what you are asking for. Yes, that sweep was an older one. I will generate a new stimulus with the current beta and will attach an .mdat with the path that is working correctly (chromecast) and incorrectly (SHD / Volumio).

Please Log in or Create an account to join the conversation.

Moderators: devteam