Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: MUTE signal to avoid startup clicks?

MUTE signal to avoid startup clicks? 4 years 2 months ago #28591

  • zarandok
  • zarandok's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Thank you received: 1
  • Karma: 1
Hi,

my problem is with USBStreamer:
if I start playing something, there are some loud clicks before the playback. A little disappointed feeling....

A possible solution could be to give out a MUTE signal (3.3V, through GPIO ???) for e.g. 0,5-1s before the playback.

The newer Streamer driver is even worse (!) because I can not turn off the standby mode, so the clicks are not only present before the first but also before all playbacks!

Let us thinking out a good and reasonable solution!
Thanks!!
The administrator has disabled public write access.

MUTE signal to avoid startup clicks? 4 years 2 months ago #28592

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1450
  • Thank you received: 667
  • Karma: 84
This is most likely an issue with your DAC and/or the interfacing to it.

My USBStreamer exhibits no clicking at all when starting tracks or switching tracks or sensing sample rate changes or etc, etc.

Dave.
The administrator has disabled public write access.

MUTE signal to avoid startup clicks? 4 years 2 months ago #28593

  • zarandok
  • zarandok's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Thank you received: 1
  • Karma: 1
I have a PCM1794 DAC w/o microcontroller (in h/w mode).
There is nothing special, the MUTE and ZERO pins are wired together, also the DAC outputs are muted when no input signals are presented.

When I use the Streamer with the older driver and it is always turned on (also not in the automatic standby mode) there is no problem after the first playing so long as the device is turned on.

Any idea?
The administrator has disabled public write access.

MUTE signal to avoid startup clicks? 4 years 2 months ago #28594

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1450
  • Thank you received: 667
  • Karma: 84
Well, I've seen it done a couple of different ways, but I think I would float the ZERO line and ground the MUTE line.
With the "closed-loop" configuration the DAC is muting/umuting all the time and it yields transitions that must be making their way through your I/V converter stage.

I don't have a PCM1794-based DAC so can't help you with experimentation.

Dave.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

MUTE signal to avoid startup clicks? 4 years 2 months ago #28603

  • zarandok
  • zarandok's Avatar
  • Offline
  • Junior Boarder
  • Posts: 25
  • Thank you received: 1
  • Karma: 1
Thanks Dave!

The DAC has a soft-mute function, so this can not cause any unnecessary noise.
It should be simply muted so long as the USBStreamer is in a "waking up"...

It would be nice to have this control signal from the Streamer, otherwise I need an external controller or some other delaying components...

And as I mentioned above, with the new drivers I can not turn off the automatic standby mode...:(
Last Edit: 4 years 2 months ago by zarandok.
The administrator has disabled public write access.

MUTE signal to avoid startup clicks? 4 years 2 months ago #28605

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1450
  • Thank you received: 667
  • Karma: 84
Ah, sorry I misunderstood your issue.
You're asking for further development of the host controller capabilities?

Dave.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

MUTE signal to avoid startup clicks? 4 years 2 months ago #28615

  • devteam
  • devteam's Avatar
  • Online
  • Administrator
  • Posts: 8776
  • Thank you received: 1172
  • Karma: 165
@ zarandok

There is a beta driver for the always on support. We'd be happy to provide it for you if that helps. Start a tech support ticket with us (support.minidsp.com) and we'll take it from there.

DevTeam
miniDSP, building a DSP community one board at a time.
The administrator has disabled public write access.
The following user(s) said Thank You: zarandok

MUTE signal to avoid startup clicks? 2 years 2 months ago #38917

  • zloypk
  • zloypk's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Same problem with AK4490 chip. Can i get new firmware with MUTE signal pin implemented?
The administrator has disabled public write access.
Moderators: devteam