Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: UMA-8 no I2S output in raw mode

UMA-8 no I2S output in raw mode 1 year 3 months ago #42843

  • bitscientist
  • bitscientist's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
Hello,

I just received a UMA-8, the marking on the board is Rev 0.5 Nov 6 2017.
However, the Readme.txt says the firmware is for board Rev 0.6 or later, did I receive an old board?

Also, I'm using firmware micArray_vf_raw_v1.0_up.bin I do not see activity on the LRCLK, BCLK, I2S_OUT_0 signals. The MCLK is active.
How do I enable the I2S signals ?

Thanks.
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 9 months 3 hours ago #46128

  • Tiger
  • Tiger's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 1
I also have the same issue. Did you figure out how to play audio in raw data mode?
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 8 months 4 weeks ago #46133

  • bitscientist
  • bitscientist's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
Hello,

No I did not get this to work. With the micArray_vf_spk_v1.2_up.bin firmware I can observe activity on the LRCLK, BCLK, I2S_OUT_0 signals and I can play audio with a I2S DAC board, that confirms the board is ok. But with micArray_vf_raw_v1.0_up.bin raw mode it does not work.

Please miniDSP, enable the digital output in raw mode! Thanks.
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 8 months 4 weeks ago #46165

  • Tiger
  • Tiger's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 1
Thank you for your response. I read one paper
homes.cs.washington.edu/~gshyam/Papers/whitenoise.pdf
anranw.me/papers/whitenoise_poster.pdf
They used UMA SP to get 7 channel audio and play audio. I current use the V2 but it doesn't work.
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 8 months 4 weeks ago #46201

  • Tiger
  • Tiger's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 1
You are right. I used the oscilloscope to test UMA-8 v2. There is no signal output on the pin I2S_OUT_0 in raw mode at all! It is oaky in DSP mode. How Minidsp delivers the product which is not as it promised!
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 7 months 4 weeks ago #46811

  • Tiger
  • Tiger's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 1
They fixed this issue now. I tested I2S_OUT_0 signals.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

UMA-8 no I2S output in raw mode 7 months 4 weeks ago #46812

  • bitscientist
  • bitscientist's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
Yes! It is working now. I connected a I2S DAC board and I have audio out now. Thanks for helping with this issue.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

UMA-8 no I2S output in raw mode 7 months 2 days ago #47211

  • vkbhat2003
  • vkbhat2003's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
What is the fix?
The administrator has disabled public write access.

UMA-8 no I2S output in raw mode 7 months 2 days ago #47212

  • vkbhat2003
  • vkbhat2003's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
What is the fix please?
The administrator has disabled public write access.
Moderators: devteam