Welcome, Guest
Username: Password: Remember me
Here is the place to share your questions/comments about your setup of the UMIK-1 USB measurement microphone


NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: UMIK-1 device descriptor request failed in win10

UMIK-1 device descriptor request failed in win10 4 months 1 week ago #46872

  • kaimaikid
  • kaimaikid's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
I have had the UMIK-1 working on my desktop PC on multiple occasions but win10 64 does not recognize it anymore



Unknown USB device (device descriptor request failed)

Yes I have pushed both ends of the cable in firmly
Yes I have set allow all apps
Yes I have tried 2 more cables to see if that works

basically I need a non-generic driver please


This message has an attachment image.
Please log in or register to see it.

Last Edit: 4 months 1 week ago by kaimaikid.
The administrator has disabled public write access.

UMIK-1 device descriptor request failed in win10 3 months 1 week ago #47405

  • Matthall
  • Matthall's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
I'm also having this problem. I was about to send it back under warranty a few months ago but it started working again. Now it looks like it's dead for good, hopefully I'm still covered.
The administrator has disabled public write access.
Moderators: devteam