Welcome, Guest
Username: Password: Remember me
This is the optional Forum header for the Suggestion Box.

TOPIC:

2x4 hd stops outputting sound 5 years 8 months ago #31968

  • carlocaccia
  • carlocaccia's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
Hi,

i have the same problem. I use the last firmware 1.6 on windows 7 pro 64 bit.
Attachments:

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31969

  • DundukovEM
  • DundukovEM's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 5
  • Thank you received: 2

Hi,

i have the same problem. I use the last firmware 1.6 on windows 7 pro 64 bit.


What usb port are you using?
Have you tried my solution?

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31970

  • carlocaccia
  • carlocaccia's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
I have the same problem

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31971

  • carlocaccia
  • carlocaccia's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
Please, Check my attachment
Attachments:

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31972

  • carlocaccia
  • carlocaccia's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
I use the USB 2.0 port, not 3.0

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 10 months ago #47203

  • petermortensen
  • petermortensen's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 1
My MiniDSP 2x4 HD stops outputting sound every few hours.
Some facts of my setup:
1. The MiniDSP box is connected via a USB hub to a USB 3.0 connector on my iMac (macOS Catalina 10.15.4 Beta).
2. I'm using a MiniDSP 1.15 with firmware is 1.9.
3. The problem disappears when disconnecting and reconnecting power on the MiniDSP box.
4. The problem does not disappear when rebooting my iMac.
5. The problem does not disappear if I switch sound output to Internal Speakers and back again to the MiniDSP box.
6. The miniDSP Mac software can connect to the box while it's in the failure mode and it doesn't appear to malfunctioning except the audio is not coming through it.

It's possible that my USB connection is not completely perfect causing some occasional noise on the data, but it most certainly shouldn't yield the audio to stop working and the box to need a reboot. I've swapped the USB cable to a direct one without a hub and will see if that does a difference.

Please Log in or Create an account to join the conversation.

Last edit: by petermortensen.

2x4 hd stops outputting sound 2 years 9 months ago #47910

  • stackedsax
  • stackedsax's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
I started having this problem today, too. The exact same symptoms as petermortensen reports.

I am on a very similar system except that I'm on 10.15.2. The 2x4HD is 1.15 with firmware 1.9.

Sound is restored after a power cycle. Sound is also restored after disconnecting and reconnecting the USB cable.

As others report, the miniDSP software can still connect to the USB port despite the sound not coming through. If I switch the input to TOSLINK while the sound from the USB is out, the TOSLINK sound works just fine. Switching back to USB does not result in working sound, however.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 9 months ago #47911

  • petermortensen
  • petermortensen's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 1
This problem went away for me after I got the ground wire of my iMac connected to ground. I had used some cable adapter between a Hong Kong connector type and USA connector type that lacked ground. After getting grounding of my iMac, it seems the sound never drops out anymore.

I had this iMac running for 2 years without grounding and it caused no other issue. Perhaps the lack of grounding caused some noise yielding USB data errors or maybe common mode current in some way could crash the audio DSP CPU.

Perhaps miniDSP didn't test the box being robust against common mode noise or data errors. Whatever it is, it should be fixed.

Please Log in or Create an account to join the conversation.

Last edit: by petermortensen.

2x4 hd stops outputting sound 2 years 9 months ago #47924

  • stackedsax
  • stackedsax's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
Glad it solved it for you.

Based on your experience, I've unplugged everything that is extraneous and double-checked that everything that can be grounded is grounded, but no dice. The 2x4 keeps dying after 30-60 seconds after a power cycle.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 9 months ago #47925

  • petermortensen
  • petermortensen's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 1
In my case, when this problem occured, I could still connect to it via the USB cable and synch etc. Only thing not working was to get audio to stream through it. Whatever makes the audio stop is obviously either a HW or SW bug in the product that miniDSP can't reproduce in their lab. When such a problem is intermittent and not appearing in the R&D lab, it can be hard for engineers to analyze and fix it. In my case, the product itself was not defective. If your box dies after only 30-60 seconds, it could be an actual defective condition for this particular box.

But to judge that, you should take the box and connect it to a completely different computer with different USB cable. If it still fails, one suspect could be your power adapter that could have too much ripple on the DC voltage. If you know what you are doing, you could try to swap the power adapter (gotta be with identical DC voltage specs and sufficient current).
In fact, power supply noise could also explain my experience with this box.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 9 months ago #47926

  • petermortensen
  • petermortensen's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 1
In my case, when this problem occured, I could still connect to it via the USB cable and synch etc. Only thing not working was to get audio to stream through it. Whatever makes the audio stop is obviously either a HW or SW bug in the product that miniDSP can't reproduce in their lab. When such a problem is intermittent and not appearing in the R&D lab, it can be hard for engineers to analyze and fix it. In my case, the product itself was not defective. If your box dies after only 30-60 seconds, it could be an actual defective condition for this particular box.

But to judge that, you should take the box and connect it to a completely different computer with different USB cable. If it still fails, one suspect could be your power adapter that could have too much ripple on the DC voltage. If you know what you are doing, you could try to swap the power adapter (gotta be with identical DC voltage specs and sufficient current).
In fact, power supply noise could also explain my experience with this box.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 9 months ago #47927

  • stackedsax
  • stackedsax's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 4
  • Thank you received: 0
Yes, my symptoms were exactly the same as yours: the sound didn't work, but I was still connected with the app and the USB control.

I'll try again with a different power supply, but it's odd that it should have worked fine for several weeks and is now acting like this.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 5 months ago #50231

  • aedagnino
  • aedagnino's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 26
  • Thank you received: 6
I'm having the exact same problems with my DDRC-24 (well, bought as 2x4 HD and then upgraded), but I'm using it with a Raspberry Pi 4 running on Picoreplayer and LMS: sound through USB input stops working and I have to do a power reboot of the minidsp, if I do it on the RPi it doesn't work. Analog input works along just fine, no problem there. I checked if it was one of the usb 2.0 outputs on the RPi, and yes it is. It's been happening for the last month or so.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 5 months ago #50232

  • petermortensen
  • petermortensen's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 18
  • Thank you received: 1
It's a bummer this problem is still not fixed. Of course this is a bug in the 2x4HD box firmware. I used to have this problem every couple of hours and after rewiring my USB connections to my iMac, the problem happens less than once a week or so now. But still it occasionally happens and it's annoying that nobody cares to fix it. This box should obviously not get "stuck" in a malfunction state that needs a reboot of it. Since the software keeps running and you can communicate with the UI features through USB, surely is't partially still running. It's as if the SHARC DSP is latched up in some way.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 2 years 5 months ago #50467

  • nkopas
  • nkopas's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 1
I'm using the USB interface running the latest firmware and drivers available. (July 2020) Every once and a while USB sound will just stop outputting similar to what's being reported here. The only thing that corrects the issue is to unplug/replug the power on the 2x4 HD.

It's not very frequent (less than once a week) but if it starts getting worse I'll either switch to TOSLINK or open a support ticket.

Please Log in or Create an account to join the conversation.

Moderators: devteam