Welcome, Guest
Username: Password: Remember me
This is the optional Forum header for the Suggestion Box.

TOPIC:

2x4 hd stops outputting sound 6 years 4 months ago #27712

  • brocha
  • brocha's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 1
i have a 2x4hd and it randomly stops playing. if i unplug it and plug it back in it works fine then maybe the next day or couple days later it stops again. thats the only thing i have tried is just to unplug it and plug it back in.i'm going to reinstall everything hopefully this isnt a hardware problem. but maybe you guys know already.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 4 months ago #27713

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3778
  • Thank you received: 1593
Which input - USB? (Just curious)

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 4 months ago #27714

  • brocha
  • brocha's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 1
yea usb and i have outputs on out 1 and out 3. i'll mess with it but for now i'm just guessing what it could be.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 4 months ago #27716

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 3778
  • Thank you received: 1593
The problem with USB is there are two "active" ends.

I think the first thing to do would be to update the firmware to the current version (if you haven't already, there was an update recently).

If it still happens, see if there's something you can do in the computer to re-establish communication e.g. does the computer still "see" the USB audio connection. This is information that would be helpful to miniDSP if you needed to open a support ticket (minidsp.desk.com), along with your OS and hardware information.
The following user(s) said Thank You: devteam

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 4 months ago #27754

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9143
  • Thank you received: 1451
@ brocha

To sum it all up
- USB audio streaming
- Audio stops playing and you have to reboot to get it back.

It does sound like maybe USB audio isn't always ON. (e.g. maybe your PC is going into sleep mode?) That could explain why audio is stopping. It's USB audio class 2, needs high speed at all times.

DevTeam
miniDSP, building a DSP community one board at a time.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 3 months ago #28248

  • catalinmarin
  • catalinmarin's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 0
Hi, Brocha,

Did you solve the problem?
I have the exact same issue with a 2x4HD that I borrowed from a friend. The problem is only with my computer, it never happened for my friend.

Thank you!

Please Log in or Create an account to join the conversation.

Last edit: by catalinmarin.

2x4 hd stops outputting sound 6 years 3 months ago #28282

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9143
  • Thank you received: 1451
@ catalinmarin

more info would help I think.. We're assuming that you're running the latest firmware + usb driver?
Which OS you're using? We need more details to be able to help.

In few cases we've investigated so far, the issue was related to sleep mode of the USB port. i.e. messing the audio. Make sure you investigate that on your OS. (i.e. sleep mode)

DevTeam
miniDSP, building a DSP community one board at a time.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 3 months ago #28297

  • catalinmarin
  • catalinmarin's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 0
Hi, devteam,

Indeed, the USB selective suspend setting was enabled. BUT i don't think that this was the culprit, because the device stopped working at random moments, sometimes at a few minutes apart, some other times at a few hours, regardless of me using or not the computer for other tasks. Unfortunately, I cannot test it with the setting enabled disabled because I have already returned the device to my friend.

More than that, in control panel in the playback devices list, I could clearly see the minidsp active and, as the music player continued to stream, the level indicator on the minidsp (in the same screen) was moving up and down signaling that at least at a software level, the device was indeed active. If I had the plugin connected to the device, at the moment the device stopped working, the plugin was also disconnecting from the device.

My friend said he updated the device to the latest firmware, but the first thing I did when I brought it home was to reset the MiniDSP-2x4-HD plugin to its factory default (in case that matters).

I have used the device as a USB DAC the whole time.

One thing I think I should mention is that I have also used the Equalizer APO for the minidsp device. My friend said that EqAPO sometimes messes with his other sound devices the same way. They stop outputting audio the same way minidsp stopped for me. Still, I have never had any problems with EqApo on my computer with my other devices (both dacs on usb, ODAC and FiiO).

My computer is a desktop computer, motherboard Asus Z170-K, i5-6600, Windows 10 Pro 64bit with latest updates, Bitdefender Total Security (if it matters..) and the minidsp device was connected to various usb 2.0 ports, still presenting the same symptoms.

Hope all this helps,

Regards,
Catalin

Please Log in or Create an account to join the conversation.

Last edit: by catalinmarin.

2x4 hd stops outputting sound 6 years 3 months ago #28364

  • brocha
  • brocha's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 1
i have updated everything and i'm using optical and have no issues anymore, thanks.
The following user(s) said Thank You: devteam

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 6 years 3 months ago #28418

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9143
  • Thank you received: 1451
@ catalinmarin

Not sure what could be the case here since we don't have much data here (from other customers or from us) to explain drop outs. We haven't heard of this before.. I wonder if it could be:
a) ASIO driver with latency too low to process APO + multichannel driver. Some PC might not have enough juice maybe? Did you try the ASIO settings?
b) Kernel streaming can be some issue on some PC. We've seen this before combined with the PC going onto sleep. We do know of that issue and it's related to make sure that the PC never put himself in sleep/power saving mode. Kernel streaming + power saving = bad combo.

Devteam
miniDSP, building a DSP community one board at a time.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31816

  • DundukovEM
  • DundukovEM's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 5
  • Thank you received: 2
Got the same problem as the author of the topic.

Randomly, the sound output drop-out at the 2x4HD when using a USB connection.
The sound disappears completely. Even Windows system sounds, YouTube etc can not be played.
At the same time, there is a connection to the device. Just the Input / Output level indicators do not show any level.
Windows audio status bar icon shows the volume level with green/gray vertical bar but no sound at all.

Only a hard reset by turning off the power helps restore sound. Sometimes it needs to be done several times a day.

System config:
Desktop PC, Win 7 Ultimate x64 SP1.

MiniDSP 2x4HD
Revision v.6.F2
Version 1.9
Firmware 1.6
Driver v.3.34.0

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31839

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9143
  • Thank you received: 1451
@ DundukovEM

We'd love to hear more from you directly via our tech support ticket so we can try to understand what could be the common trigger here.
We now have a LOT of 2x4HD in the field, we're not aware of a hardware/firmware issue. Something must be triggering that issue on the software we believe... Can you please confirm your buffer settings under the driver? Maybe a trigger here.

Anyway, please start an official tech support ticket with our team (support.minidsp.com). We can take it from there.
miniDSP, building a DSP community one board at a time.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31865

  • DundukovEM
  • DundukovEM's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 5
  • Thank you received: 2
I think I figured out the problem and found ways to solve it.
The source of the problems is USB 3.0 port on the computer.

I initially did not pay attention to which port to connect miniDSP 2x4HD, since the PC has a lot of USB2.0 and USB 3.0 ports.
It turns out that I was connected to USB 3.0 port.
It does not matter what settings were in the Buffer Settings tab in the miniDSP driver.
I tried all options - still the sound dropped-out randomly.
Then, I switched the cable to the USB 2.0 port on the back of the computer - and all problems have disappeared by a wave of a magic wand.

So the appeal to developers is to conduct an extended testing of devices with USB 3.0 / 3.1 ports for possible incompatibilities.

P.S. It took about a week since switching to the USB 2.0 port, during which the device was used daily, and there was not a single case of sound loss.
The following user(s) said Thank You: devteam

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31873

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9143
  • Thank you received: 1451
@ DundukovEM

Very interesting indeed! We know that Mac is no problem under USB3.0... I think that it's most likely some driver issue somewhere to investigate. Can you please tell us more of your PC specs and the chipset used for USB3.0?

Thanks!
miniDSP, building a DSP community one board at a time.

Please Log in or Create an account to join the conversation.

2x4 hd stops outputting sound 5 years 8 months ago #31876

  • DundukovEM
  • DundukovEM's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 5
  • Thank you received: 2
The PC has the following configuration:
CPU: Intel Core i5 4460
Motherboard: Asus Z97-A BIOS 2801
Chipset: Intel Z97 Express
Chipset Device driver: 10.1.1.42
MS Windows 7 Ultimate x64 SP1
The following user(s) said Thank You: devteam

Please Log in or Create an account to join the conversation.

Moderators: devteam