Welcome, Guest
Username: Password: Remember me
Need help configuring your plug-ins? This is the place to ask the miniDSP community for help. Please read manual first to limit 101 questions.

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.
  • Page:
  • 1

TOPIC:

miniDSP 2x4HD; UMIK2 3 months 3 weeks ago #62347

  • Stullexy
  • Stullexy's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 1
  • Thank you received: 0
Greetings
I'm not sure if my problem is in the right place.

I have had a miniDSP 2x4 HD for a long time and have now bought the UMIK 2 to go with it. Now I have made a firmware update to FW v2_06 with the UMIK 2 (I thought). But this update was applied by the tool "miniDSPUAC2Dfu" on my 2x4 HD instead of the UMIK2! Now my 2x4HD no longer works and is recognized in Windows10 as UMIK2! Unfortunately I can not flash my 2x4HD back to the old or current firmware. I hope you can help me save the miniDSP 2x4HD.

Translated with www.DeepL.com/Translator (free version)

Please Log in or Create an account to join the conversation.

miniDSP 2x4HD; UMIK2 3 months 3 weeks ago #62351

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2535
  • Thank you received: 526
You should contact the official miniDSP Support using the link at the top of the page. I hope I am wrong but you may have to send your device back to miniDSP to solve this problem.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: devteam