Welcome, Guest
Username: Password: Remember me
Need help configuring your plug-ins? This is the place to ask the miniDSP community for help. Please read manual first to limit 101 questions.

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.
  • Page:
  • 1

TOPIC:

Couldn't download from newbie 11 months 1 week ago #56859

  • Faithwell
  • Faithwell's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
  • Thank you received: 0
Tried to download miniDSP 2x4HD & UMIK-1 plug-ins but not successful. Any help much appreciated.

Please Log in or Create an account to join the conversation.

Couldn't download from newbie 11 months 1 week ago #56860

  • Faithwell
  • Faithwell's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
  • Thank you received: 0
Finally managed to download by following the steps each time if you wish to download different software.

Please Log in or Create an account to join the conversation.

Couldn't download from newbie 8 months 1 week ago #57975

  • istealth
  • istealth's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 8
  • Thank you received: 1
In order not to create new threads, I thought I would ask here. I recently got a minidsp 2x4HD from a friend of mine with the software that he downloaded long time ago. When I run the plugin, I can see that the software version is 1.17 and the firmware is 1.14. I was wondering if those are the lates one available by now or there is a newer version. 

Thanks!
 

Please Log in or Create an account to join the conversation.

Couldn't download from newbie 8 months 1 week ago #57976

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2153
  • Thank you received: 426

In order not to create new threads, I thought I would ask here. I recently got a minidsp 2x4HD from a friend of mine with the software that he downloaded long time ago. When I run the plugin, I can see that the software version is 1.17 and the firmware is 1.14. I was wondering if those are the lates one available by now or there is a newer version. 

Thanks!

 

They are current but if you contact support with the serial number of your device you'll be able to have access to any future updates yourself.
The following user(s) said Thank You: istealth

Please Log in or Create an account to join the conversation.

Couldn't download from newbie 8 months 1 week ago #57978

  • istealth
  • istealth's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 8
  • Thank you received: 1
Thanks! Good to know that there are no further updates so far. I actually have doubts that with the serial number they could provide any access to the plugin because on the website is says that it cost $10. 

Please Log in or Create an account to join the conversation.

Couldn't download from newbie 8 months 1 week ago #57979

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2153
  • Thank you received: 426

Thanks! Good to know that there are no further updates so far. I actually have doubts that with the serial number they could provide any access to the plugin because on the website is says that it cost $10. 

You have nothing to lose by asking...

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: devteam