Welcome, Guest
Username: Password: Remember me
NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC:

roon stop support for uncertified devices ! 11 months 3 weeks ago #57996

  • devteam
  • devteam's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 9136
  • Thank you received: 1426
Dear All

Thanks for all the feedback and glad to hear that you're enjoying your unit with Roon. :-)
- If you have Volume control not tracking (or affecting the audio), it's 99% confirmed that you're running a very old firmware on your SHD.. We could be wrong but that's the case as 1year ago we released firmware to support for volume control. Warning to prevent some confusion, we're talking of the SHD "firmware", not Volumio build as some of you might get confused from what we've seen. These are 2 completely different piece of software. You can upgrade your firmware from the User downloads section, grab the manual p77, we explain everything in details. :-) 
- As for the remote, we're sorry for this minor bug. We've already made mention to Volumio and are just waiting for an update. It's a very minor bug (sticking value) that will be fixed easily. In the mean time, you have many ways to control your SHD + Roon though.. (Web GUI, Roon Gui, Roon App... ) :-) Thanks for your patience. 

If any other issues, please remember to use our support portal. That's where our engineers/support team will help. We see some of you getting upset with some issues and can always get support directly from our team as per the disclaimer from above. Thanks for your understanding and have fun! 

DevTeam
miniDSP, building a DSP community one board at a time.
The following user(s) said Thank You: robaroy62, ndtrnc, Nick V

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58093

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9
I updated the SHD NEO3 to verion 1.111 and there is no Roon Ready Plugin available. Only the Roon Bridge is shown.
I have done two factory resets. What I am missing?

- Rich

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58094

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9
I updated the SHD NEO3 to verion 1.111 and there is no Roon Ready Plugin available. Only the Roon Bridge is shown.
I have done two factory resets. What am I missing?

- Rich

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58095

  • Jeff328gts
  • Jeff328gts's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 4
There is no plugin for Roon Ready. It's part of the basic Volumio build.  It's enabled in the settings section and is enabled by default if you do a factory reset of Volumio. Have you checked in Roon to see if your SHD is shown? If it's not, reboot your Roon core server.

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58113

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9

There is no plugin for Roon Ready. It's part of the basic Volumio build.  It's enabled in the settings section and is enabled by default if you do a factory reset of Volumio. Have you checked in Roon to see if your SHD is shown? If it's not, reboot your Roon core server.

 

Thanks that worked great!
@devteam,

Please correct the manual that states that I need to scroll down and enable Roon Ready. The documentation sent me down a rabbit hole. ;)
Serves me right for reading the manual. I'll be turning in my man-card.

 

- Rich
Attachments:

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58116

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9
Now that Roon is working, it is forcing all content to be converted to 96 kHz.
For example, 44.1 kHz should conversion is force after the SHD.



Also, 176.4 kHz that I believe is support by the SHD is down converted to 96 kHz.

This behavior does not seem right.

- Rich
Attachments:

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58117

  • Jeff328gts
  • Jeff328gts's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 4
SHD *input* supports lots of data rates.

But it converts everything to 96khz internally for processing. You just never had a way to see that happening before.

And, the SHD digital outputs (if you use them) only output 96 kHz no matter what your input is.
The following user(s) said Thank You: Ultrasonic

Please Log in or Create an account to join the conversation.

Last edit: by Jeff328gts. Reason: Added output info

roon stop support for uncertified devices ! 11 months 2 weeks ago #58118

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9

SHD *input* supports lots of data rates.

But it converts everything to 96khz internally for processing. You just never had a way to see that happening before.

And, the SHD digital outputs (if you use them) only output 96 kHz no matter what your input is.


I have found that, for whatever reason, changing sample rates has an audible affect.
After a quick test, I think it sounds better sample rate convert in Roon (that uses 64-bit floating point) and send 96 kHz to Roon.

- Rich

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58120

  • petewilson
  • petewilson's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 11
  • Thank you received: 2
Rich, 
You said "After a quick test, I think it sounds better sample rate convert in Roon (that uses 64-bit floating point) and send 96 kHz to Roon."

I assume you mean 'After a quick test, I think it sounds better sample rate convert in Roon (that uses 64-bit floating point) and send 96 kHz to the SHD from Roon'

To do this, make sure that Roon's 'settings' for the SHD have 96 KHz set for max PCM rate; and then get hold of the DSP settings for the SHD and turn on 'Sample rate conversion' selecting the 'Max PCM rate' setting..

However - a question - is it better to use 24 bit or 32 bit data?

-- Pete

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58123

  • RichB
  • RichB's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 51
  • Thank you received: 9

Rich, 
You said "After a quick test, I think it sounds better sample rate convert in Roon (that uses 64-bit floating point) and send 96 kHz to Roon."

I assume you mean 'After a quick test, I think it sounds better sample rate convert in Roon (that uses 64-bit floating point) and send 96 kHz to the SHD from Roon'

To do this, make sure that Roon's 'settings' for the SHD have 96 KHz set for max PCM rate; and then get hold of the DSP settings for the SHD and turn on 'Sample rate conversion' selecting the 'Max PCM rate' setting..

However - a question - is it better to use 24 bit or 32 bit data?

-- Pete

The Roon thinks the MiniDSP SHD supports 192kHz, probably because it advertises that it does.
When the Max is set to the default 128khz, the MiniDSP Sample Rate Conversion Maximum support is shown for each rate and it will convert to 96kHz.
When the settings is set to 96kHz, the Maximum Rate option is not shown.
In either case, I select the highest multiple of 2 directly, because that option is not available after lowering the device settings to 96kHz.
 

Since the MiniDSP DAC does not support 32 bits, there is no option for it.

EDIT: The maximum sample rate and highest power of 2 have disappeared after restarting Roon. Wierd.

- Rich
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by RichB.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58148

  • Stouthart
  • Stouthart's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 56
  • Thank you received: 8
Funny, when using Roon via USB (via RPI) you can still select the SHD Studio. And..then it's lossless ;-)
Attachments:

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58149

  • Jeff328gts
  • Jeff328gts's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 16
  • Thank you received: 4
That’s because through the rpi Roon has no idea what is happening inside the SHD device.

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 11 months 2 weeks ago #58150

  • Stouthart
  • Stouthart's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 56
  • Thank you received: 8
Duh...guess you missed the smiley 

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 10 months 4 weeks ago #58387

  • tariqkhokhar
  • tariqkhokhar's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 1
  • Thank you received: 1
A quick note to say thank you to the Devteam for all your work in getting the SHD working well with Roon. Have been content using workarounds for most of the year but just noticed this post, updated my firmware, and Roon happily started streaming to my SHD Studio immediately - much nicer experience and sounds great!
The following user(s) said Thank You: Juoigâ

Please Log in or Create an account to join the conversation.

roon stop support for uncertified devices ! 10 months 2 weeks ago #58661

  • jchoaus
  • jchoaus's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 3
  • Thank you received: 0
Anyone else still experiencing pops with DSD?

Please Log in or Create an account to join the conversation.

Moderators: devteam