Welcome, Guest
Username: Password: Remember me
NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: SHD built-in streamer volume level

SHD built-in streamer volume level 3 months 3 weeks ago #49008

  • akostu
  • akostu's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
Hi!

For some reason when I feed SPDIF digital signal into SHD from my RPI 3b+ / DAC502 HAT streamer, the volume level is noticeably higher than when using SHD internal streamer.

Does it mean that SHD internal streamer is not bit perfect?

Anton
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 3 weeks ago #49021

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 749
  • Thank you received: 139
  • Karma: 14
Is this playing the same track from the same streaming service on both devices? Assuming yes it would be worth checking that all settings match as well, with most obviously volume normalisation being enabled for one and not the other being a possible cause of the difference.
Last Edit: 3 months 3 weeks ago by Ultrasonic.
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 3 weeks ago #49024

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1409
  • Thank you received: 661
  • Karma: 82
You need to set the Volumio level to 100. Playing an identical track would then yield the same volume level.

The volume normalization quirk is another variable, but that doesn't sound like the issue here.

Dave.
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 3 weeks ago #49025

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 749
  • Thank you received: 139
  • Karma: 14
dreite wrote:
You need to set the Volumio level to 100.

The Volumio level should always match the SHD master volume though, so it's not obvious to me that this should be a factor in the test, and so importantly shouldn't need to be at 100. A level that in virtually all systems will be way too loud. Potentially dangerously so for either hardware or hearing.
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 3 weeks ago #49026

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1409
  • Thank you received: 661
  • Karma: 82
Possibly.
However, he might have an incomplete update to the later firmware/software changes which forced the tracking of the volume settings. He doesn't indicate what software iteration his unit is at.

Gain structure elsewhere in the system is a factor. I have my SHD setting at 100 (0db) occasionally when listening to source material that's recorded at levels significantly lower than 0dbFS. So, it's not necessarily dangerous.

Regardless, there's nothing inherent in the two paths that would cause a volume difference........all other things being equal.

Dave.
Last Edit: 3 months 3 weeks ago by dreite. Reason: correction
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 2 weeks ago #49207

  • bertrijsdijk
  • bertrijsdijk's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
If you are using Spotify connect you might want to check the Spotify plugin output level is not fixed and then put it on 100%. This is a separate setting from the overal volume setting for the device (took me a while to figure this out).

If you do it should give you exactly the same volume output as playing the stream from another (external) source

This message has an attachment image.
Please log in or register to see it.

Last Edit: 3 months 2 weeks ago by bertrijsdijk.
The administrator has disabled public write access.
The following user(s) said Thank You: Ultrasonic

SHD built-in streamer volume level 3 months 2 weeks ago #49285

  • akostu
  • akostu's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
del double post
Last Edit: 3 months 2 weeks ago by akostu. Reason: double post
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 2 weeks ago #49286

  • akostu
  • akostu's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Karma: 0
Yes, that was it! Many thanks!!! I would not have come up on this myself.
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 2 weeks ago #49291

  • rodrigaj
  • rodrigaj's Avatar
  • Offline
  • Senior Boarder
  • Posts: 61
  • Thank you received: 15
  • Karma: 0
bertrijsdijk wrote:
If you are using Spotify connect you might want to check the Spotify plugin output level is not fixed and then put it on 100%. This is a separate setting from the overal volume setting for the device (took me a while to figure this out).

If you do it should give you exactly the same volume output as playing the stream from another (external) source


My plugin choices are different - no Gapless and Autoplay options:



Why is that?

This message has an attachment image.
Please log in or register to see it.

Last Edit: 3 months 2 weeks ago by rodrigaj. Reason: Ending question.
The administrator has disabled public write access.

SHD built-in streamer volume level 3 months 2 weeks ago #49293

  • Ultrasonic
  • Ultrasonic's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 749
  • Thank you received: 139
  • Karma: 14
What version of Volumio are you running @bertrijsdijk ? My guess is it's an old one...
The administrator has disabled public write access.
Moderators: devteam