Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: How to disable IR sensor?

How to disable IR sensor? 3 years 9 months ago #23133

  • watchnerd
  • watchnerd's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 0
I've discovered that the infrared sensor on my OpenDRC-DI uses the same command as the 'Menu' button on my AppleTV remote.

This causes the DSP unit to change input setting (i.e. from Optical to another) every time I hit the 'Menu' button on my AppleTV remote.

Is there a way to disable the IR sensor or otherwise get it to ignore this command?
The administrator has disabled public write access.

How to disable IR sensor? 3 years 9 months ago #23135

  • markus
  • markus's Avatar
  • Offline
  • Senior Boarder
  • Posts: 68
  • Thank you received: 21
  • Karma: 0
You need to reassign the IR commands your unit responds to. This is done with the Utility app for your unit.

I agree that a simpler solution would be an on/off switch for the IR sensor.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

How to disable IR sensor? 3 years 8 months ago #23197

  • devteam
  • devteam's Avatar
  • Offline
  • Administrator
  • Posts: 8533
  • Thank you received: 1052
  • Karma: 157
@ watchnerd

Markus is right. You simply reprogram the remote with some empty presets. i.e. click "LEARN", just don't show any IR. That will do the trick.

DevTeam
MiniDSP, building a DIY DSP community one board at a time.
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23229

  • watchnerd
  • watchnerd's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 0
devteam wrote:
@ watchnerd

Markus is right. You simply reprogram the remote with some empty presets. i.e. click "LEARN", just don't show any IR. That will do the trick.

DevTeam

Nope, that didn't work. Nor did trying to get it to learn the commands from a completely different remote.

Can't you just patch this in software so the IR can be disabled?
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23244

  • dreite
  • dreite's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 1270
  • Thank you received: 630
  • Karma: 82
You have no green check marks on your IR learning/remote drop-down menu and it's STILL responding to IR commands??
Until you find a better solution, just block off the IR sensor. :)

Dave.
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23246

  • watchnerd
  • watchnerd's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 0
dreite wrote:
You have no green check marks on your IR learning/remote drop-down menu and it's STILL responding to IR commands??
Until you find a better solution, just block off the IR sensor. :)

Dave.

Yep, that's exactly the case. No green check marks, still responding to IR commands. :angry: :(
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23265

  • markus
  • markus's Avatar
  • Offline
  • Senior Boarder
  • Posts: 68
  • Thank you received: 21
  • Karma: 0
watchnerd wrote:
dreite wrote:
You have no green check marks on your IR learning/remote drop-down menu and it's STILL responding to IR commands??
Until you find a better solution, just block off the IR sensor. :)

Dave.

Yep, that's exactly the case. No green check marks, still responding to IR commands. :angry: :(

If you don't see the checkmarks learning failed. What steps are you performing for learning commands?
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23267

  • watchnerd
  • watchnerd's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 0
markus wrote:
watchnerd wrote:
dreite wrote:
You have no green check marks on your IR learning/remote drop-down menu and it's STILL responding to IR commands??
Until you find a better solution, just block off the IR sensor. :)

Dave.

Yep, that's exactly the case. No green check marks, still responding to IR commands. :angry: :(

If you don't see the checkmarks learning failed. What steps are you performing for learning commands?

I've done it both ways:

Method 1, Grab Another Remote:

Take it through the IR learning steps using a button on a remote I don't use. It successfully registered learning each command.

All the check marks were green.

But that didn't make a difference. So I tried..

Method 2, Invoke Learning Failure:

Take it through the IR learning steps with no IR command beamed at it. It failed all of them.

None of the check marks were green.

And that still didn't make a difference.

FWIW, the unit seems to be responding in a way that doesn't map to the IR commands on the menu.

When I press 'Back' on the AppleTV remote it causes the OpenDRC-DI to go to the next input in a round-robin fashion. In other words, if I keep pressing it, it will toggle AES->OPTICAL->SPDIF->AES etc.
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23268

  • markus
  • markus's Avatar
  • Offline
  • Senior Boarder
  • Posts: 68
  • Thank you received: 21
  • Karma: 0
What kind of remote did you use? Try to learn ALL possible buttons with the new remote. Use just numbers and unusual buttons for now.
Last Edit: 3 years 8 months ago by markus.
The administrator has disabled public write access.

How to disable IR sensor? 3 years 8 months ago #23271

  • watchnerd
  • watchnerd's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 1
  • Karma: 0
markus wrote:
What kind of remote did you use? Try to learn ALL possible buttons with the new remote. Use just numbers and unusual buttons for now.

Okay, finally got it to work.

Got the LG tv remote, programmed 1, 2, 3, etc, into all the functions.

Seems to be okay now.
The administrator has disabled public write access.
Moderators: devteam