Welcome, Guest
Username: Password: Remember me
Main forum for support questions you may have for the community. Post your issues and we'll all try to help resolve them.

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: Popping sound

Popping sound 1 week 4 days ago #44381

  • Exclusive
  • Exclusive's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Hi all,

i have research regarding the popping sound that commonly occurs in the 2x4 and ddrc 88a, i have tried the solution of having them turn ON all the time but whenever i tried turning on my sub, there is always a loud pop sound.

what else can i do the eliminate the pop sound? im afraid that its damaging to the sub. :( :( :(
The administrator has disabled public write access.

Popping sound 1 week 33 minutes ago #44437

  • Juoigâ
  • Juoigâ's Avatar
  • Offline
  • Expert Boarder
  • Posts: 126
  • Thank you received: 19
  • Karma: 8
I have no experience with the 88a, but the way the 2x4 is designed means there can be a pop on power off. most use the solution to leave it turned on all the time (very low power consumption). another option is a solution whre the power amp is last on/first off
The administrator has disabled public write access.
The following user(s) said Thank You: Exclusive

Popping sound 5 days 12 hours ago #44453

  • Exclusive
  • Exclusive's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
Juoigâ wrote:
I have no experience with the 88a, but the way the 2x4 is designed means there can be a pop on power off. most use the solution to leave it turned on all the time (very low power consumption). another option is a solution whre the power amp is last on/first off

thanks for the response.
im currently using option 2 as mentioned by you, turning ON amp (sub) last.
The administrator has disabled public write access.
Moderators: devteam