Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: MCHStreamer input issues

MCHStreamer input issues 6 months 1 week ago #47168

  • karusubbu
  • karusubbu's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 4
  • Karma: 0
I am trying to understand the difference in behavior when different sources are connected to MCHStreamer TOSLink input. The audio is CD quality 44.1KHz.

1. When I connect a CD player I am able to capture audio on computer and the sound comes out fine .
2. When I connect a ADC which has a DIT interface the sound on my computer is distorted with lot of noise and the audio stream seems broken.

In order to validate the output of the ADC, I connected it to a standalone DAC which takes TOSLink input, the audio was fine without any distortion.

I have been trying to get the MCHStreamer work reliably for the past few months and keep hitting a roadblock even with a simple use case I just explained above.

With I2S inputs, the issue is even worse. I have set my ADC to slave since MCHStreamer will be master. I connected the ADC outputs with the given cable and loaded AllRate firmware on MCHStreamer. In this case I hear music for 1 or 2 secs followed by noise for 1 or 2 sec and this keeps repeating.

I would appreciate if devteam can look into this message and provide some pointers on isolating the issue and getting the MCHStreamer work.
The administrator has disabled public write access.