Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: MCHStreamer TDM input from ICS-52000 MEMS Mics

MCHStreamer TDM input from ICS-52000 MEMS Mics 1 year 2 weeks ago #44371

  • alexmstahl
  • alexmstahl's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
Hello,

I have connected an MCHStreamer to an Invensense TDM Microphone array demo board. (www.invensense.com/download-pdf/an-00009...ay-demo-board-guide/). It works very well!

Now, I am trying to connect the same MCHStreamer to four NotWired NW-AUD-ICS52000 boards .(www.notwired.co/datasheets/notwired/ds-nw-aud-ics52000.pdf). This board uses the same ICS-52000 and a very similar schematic. However it is not working properly. I just see low level crackling noise on the active channels.

I have compared the clocks and data signals, probing the MCHStreamer pins as well as the signals at the microphone chips. I have double-checked and rebuilt my connecting cables, using short leads and good grounding. I have yet to find any differences to explain why one board works and the other does not work. The TDM data stream looks similar, yet again with the Invensense board I hear good-quality audio and with the NW board, I just hear some noise.

My best guess is a timing skew on the SD net, just enough to invalidate the setup time requirement. But I have not been able to see this, just a guess.

Has anyone used the NW-AUD-ICS52000 boards successfully? Thanks in advance for any suggestions.
The administrator has disabled public write access.

MCHStreamer TDM input from ICS-52000 MEMS Mics 11 months 3 weeks ago #44631

  • devteam
  • devteam's Avatar
  • Offline
  • Administrator
  • Posts: 8764
  • Thank you received: 1155
  • Karma: 165
@alexmstahl

We've never used that board I'm afraid... Maybe ask Notwired for support knowing that they would know their board better?
knowing the Invensense works, it sounds like something specific to their board.

WE assume that you've got short leads and troubleshooted with a scope to check the signal integrity?

Devteam
miniDSP, building a DSP community one board at a time.
The administrator has disabled public write access.