Welcome, Guest
Username: Password: Remember me
NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: Mini DSP not charging after replacement

Mini DSP not charging after replacement 1 year 3 months ago #43291

  • mazeking
  • mazeking's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Thank you received: 1
  • Karma: 0
Hi,

I have received an mini dsp which charging issues. I accepted a battery replacement which was straight forward and easy to perform. Then I did not use it for some time due do work abroad.

This week I tried to charge and use it. Charging for several hours but it is not possible to turn it on
I opened it and cannot see any battery swelling or other errors. The battery connector is firmly connected to the motherboard.

When I try to charge the HA-DSP the red charging light on the back flashes aprox every second continously and steady.
The blue lights flash in the following way.:
1 : Blue light 1 and light 3 flashes for 1 second.
2: the first blue light flashes rapidly 20 times
3 : repeat steps 1 to 2 forever

Does anyone know what these lights indicate?
The administrator has disabled public write access.
The following user(s) said Thank You: fabifri

Mini DSP not charging after replacement 1 year 3 months ago #43590

  • devteam
  • devteam's Avatar
  • Offline
  • Administrator
  • Posts: 8767
  • Thank you received: 1156
  • Karma: 165
@mazeking

Sorry for this issue.. It does sound like an issue with the firmware. This issue was already solved by our team.
Please start a tech support tix (support.minidsp.com) and we'd be happy to help.

DevTeam
miniDSP, building a DSP community one board at a time.
The administrator has disabled public write access.

Mini DSP not charging after replacement 1 year 2 months ago #43777

  • fabifri
  • fabifri's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
I have EXACTLY the problem described by mazeking. First i thought i am alone with the issue. I already got a replacement battery but it never solved the charging problem. But now my HA-DSP keeps flasing and cycling like mazekings. I cannot even update to the newly released firmware. I opened a support case and hope they will get back to me soon.

Other than that, i like the HA-DSP a lot, as there is no other comparable product on the market. ;-)

best regards,
Fabian
The administrator has disabled public write access.
Moderators: devteam