Welcome, Guest
Username: Password: Remember me
NOTE: This forum is community powered. Please be mindful that long time community members are here to help as part of a community effort. If you have a specific issue (e.g. hardware, failure), please use our tech support portal (Support menu - > Contact Us). Thanks a lot of your help in making a better community. :-)

TOPIC: HA-DSP issues turning on

HA-DSP issues turning on 8 months 1 day ago #40199

  • phamd4
  • phamd4's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Karma: 0
Hello guys,

I'm new to this and just received my DSP, there was one post about the amp have problem. I just got mine today brand new and have similar issue but worse. Plug in computer, amp doesn't recognize, plug in charger, no light indicate charging, use volume knob with usb cable connect to charger (same as plugged in computer) first led light keep flashing blue. No audio or anything indicate the unit is working.

Can someone please help me?

I just contacted minidsp but haven't heard from them yet
The administrator has disabled public write access.

HA-DSP issues turning on 7 months 1 week ago #40823

  • Nallohki
  • Nallohki's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
  • Karma: 0
I am having the same issue and contacted support over a week again with no peep of a response.

I've also attempted to make a thread about it here twice in the last 3 weeks and nothing shows up.

Did you ever find a resolution for your problem?
The administrator has disabled public write access.

HA-DSP issues turning on 4 months 2 weeks ago #42075

  • ClaytonJ2
  • ClaytonJ2's Avatar
  • Online
  • Fresh Boarder
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
I am having this issue also. I shut it off, it has plenty of time to charge, I turn it on and one blue light flashes. Seems to help to plug it in to a USB charge only and then reconnect it to the PC after some time.
The administrator has disabled public write access.

HA-DSP issues turning on 4 months 1 week ago #42158

  • scan80269
  • scan80269's Avatar
  • Offline
  • Senior Boarder
  • Posts: 42
  • Thank you received: 2
  • Karma: 0
Please take a look at this thread:

www.minidsp.com/forum/dsp-headphone-amp/...-dsp-turn-on-failure

If your HA-DSP turn-on symptoms match what I reported in this thread, then you will need an internal battery replacement. Contact miniDSP support for assistance.

miniDSP offered me a choice of shipping my HA-DSP back to them or receiving a replacement battery from them and perform the battery replacement myself. I went for the latter option (I'm very experienced in electronics) which saved me time and money to restore my unit.
The administrator has disabled public write access.
Moderators: devteam