Welcome, Guest
Username: Password: Remember me
NOTE: This forum is community powered. Please be mindful that long time community members are here to help as part of a community effort. If you have a specific issue (e.g. hardware, failure), please use our tech support portal (Support menu - > Contact Us). Thanks a lot of your help in making a better community. :-)

TOPIC: Incorrect FIR filter calculations?

Incorrect FIR filter calculations? 1 month 6 days ago #33048

Hi,

Just got my HA-DSP box, and I am trying to get some filters in it. The problem is that the filter response it generates from the coefficients I input is different from what it should be.
Here is an example: In manual mode I entered these coefficients:

b0 = -0.00138008007054446,
b1 = -0.00448888849220108,
b2 = -0.00481186038570366,
b3 = 0.00354017958302429,
b4 = 0.0158396094459881,
b5 = 0.0165600017496917,
b6 = 0.00158406911727531,
b7 = -0.00885644417433574,
b8 = 0.00201782432197531,
b9 = 0.01577926605275,
b10 = 0.0044187341128959,
b11 = -0.0173146846022992,
b12 = -0.00882701595657375,
b13 = 0.0216627532141136,
b14 = 0.0178760560149397,
b15 = -0.0246306137981313,
b16 = -0.0306470294418782,
b17 = 0.0276766005854724,
b18 = 0.0525883624121027,
b19 = -0.0298188985949351,
b20 = -0.0991815131119146,
b21 = 0.0312551224852932,
b22 = 0.315980016170005,
b23 = 0.468293270612615,
b24 = 0.315980016170005,
b25 = 0.0312551224852932,
b26 = -0.0991815131119146,
b27 = -0.0298188985949351,
b28 = 0.0525883624121027,
b29 = 0.0276766005854724,
b30 = -0.0306470294418782,
b31 = -0.0246306137981313,
b32 = 0.0178760560149397,
b33 = 0.0216627532141136,
b34 = -0.00882701595657375,
b35 = -0.0173146846022992,
b36 = 0.0044187341128959,
b37 = 0.01577926605275,
b38 = 0.00201782432197531,
b39 = -0.00885644417433574,
b40 = 0.00158406911727531,
b41 = 0.0165600017496917,
b42 = 0.0158396094459881,
b43 = 0.00354017958302429,

These coefficients should output such filter (see attachment, basically a Lowpass at 12kHz).


But this is the response the HS-DSP generates (see attachment):


The filter was generated for 44.1kHz, and HA-DSP is running at 44.1kHz sample rate.

Can someone explain what is going on, what am I missing?

This message has attachments images.
Please log in or register to see it.

The administrator has disabled public write access.

Incorrect FIR filter calculations? 1 month 6 days ago #33050

  • john.reekie
  • john.reekie's Avatar
  • Offline
  • Platinum Boarder
  • Posts: 2721
  • Thank you received: 1129
  • Karma: 114
Hi, the HA-DSP is running (internally) at 96 kHz I believe.
I am not miniDSP support.

"You must ask the right questions." - Dr. Alfred Lanning's hologram.
-> Have you read the User Manual??
-> Have you drawn and posted a diagram?
-> Have you posted a screenshot?
-> Have you posted your config file?
The administrator has disabled public write access.
The following user(s) said Thank You: devteam, KarlisAuzins

Incorrect FIR filter calculations? 1 month 6 days ago #33051

  • eclipseaudio
  • eclipseaudio's Avatar
  • Offline
  • Senior Boarder
  • Posts: 48
  • Thank you received: 45
  • Karma: 8
Comment changed. My original was superfluous.
(The forum doesn't appear to allow deleting.)

Kind regards,
Michael
Eclipse Audio
Maker of FIR Designer, a filter design tool for loudspeakers.
www.eclipseaudio.com.au
Last Edit: 1 month 6 days ago by eclipseaudio.
The administrator has disabled public write access.
Time to create page: 0.103 seconds