Welcome, Guest
Username: Password: Remember me

NOTE: This is a "Community" forum. Please be mindful that community members are here to help as part of a community effort. We therefore appreciate your effort in keeping this forum a happy place!

If you have a specific issue (e.g. hardware, failure) and want help from our support team, please use our tech support portal (Support menu - > Contact Us).
Thanks a lot of your help in making a better community.

TOPIC: DDRC 88A only playing out of right speaker

DDRC 88A only playing out of right speaker 3 months 3 days ago #48423

Not sure what's going on but I am using the RCA input/outputs, and before/after running calibration tool it's only playing out of the right side. I've opened up a ticket but its taking a long time for admin to respond. Any help or suggestions would definitely be appreciated!
The administrator has disabled public write access.

DDRC 88A only playing out of right speaker 3 months 17 hours ago #48466

  • rts100x5
  • rts100x5's Avatar
  • Offline
  • Gold Boarder
  • Posts: 178
  • Thank you received: 37
  • Karma: 0
Assuming your connections are correct .(.preamp outputs to ddrc88 inputs / ddrc88 outputs to amplifier inputs) your problem is most likely your ROUTING page has not been setup correctly ...it should look like this (disregard the LFE set to OFF if you do not use Bass management

This message has an attachment image.
Please log in or register to see it.

The administrator has disabled public write access.

DDRC 88A only playing out of right speaker 2 months 4 weeks ago #48501

I did some trouble shooting and found that it was a bad cord so it solved the problem. I have a stereo system, but have 2 subwoofers and tuned the room as a stereo system and not custom system with 4 speakers. I hear the correction made by the 88A and is a huge difference as you can see by the corrected frequencies below--and myself personally have been in my room for over 10 years and have gotten used to the extra bump in the 40-80hz range--so now I feel like some of the low end is missing now.

My question now is, do I need to re tune the room with the custom setup, and route accordingly in the BM plug in, or can I just adjust the curve in the calibration tool to "feel" the low end more?

When I went into the BM plug in you can see my routing, as I have rolled off 80 hz and below on both FL in 1 and FR in 1, and the LFE Mgt on both I rolled off 80 hz and higher. Any suggestions are welcomed. Thanks again!


This message has attachments images.
Please log in or register to see it.

The administrator has disabled public write access.
Moderators: devteam