Welcome, Guest
Username: Password: Remember me
NOTE: This forum is community powered. Please be mindful that long time community members are here to help as part of a community effort. If you have a specific issue (e.g. hardware, failure), please use our tech support portal (Support menu - > Contact Us). Thanks a lot of your help in making a better community. :-)

TOPIC: No audio win8.1 + usbstreamer b box + ddrc-22d

No audio win8.1 + usbstreamer b box + ddrc-22d 2 months 2 weeks ago #31454

  • CSAVELL
  • CSAVELL's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
  • Karma: 0
UPDATE: problems mostly solved. I re-ran dirac measurements and reloaded filters on the ddrc22, and now i am getting audio by connecting the PC's built-in optical output to the ddcr22 optical input. So it looks like there's an issue with either the usbstreamer and its config or the optical cables. I want to use the usbstreamer instead of the PC's built-in sound card so will continue troubleshooting that.

This is a brand-new install, hardware just received today.
I want to have this config:

* 2-channel stereo only
* win8.1 PC USB out > usbstreamer b box USB in
* usbstreamer b box optical out > ddrc-22d optical in
* ddrc-22d optical out > integrated amp optical in

Here are the symptoms I am having:

* dirac test tones play fine and I was able to generate filters and load them onto the ddrc-22d
* When playing audio from win8.1...
- no audio from ddrc-22d when configured as above
- no audio when bypassing ddrc-22d and connecting usbstreamer optical output to the integrated amp optical in
- no audio when bypassing usbstreamer and connecting PC optical out to ddrc-22d optical in

Here are the steps I have done:

* connect usbstreamer driver to PC and load the miniDSP driver
* use firmware update utility to download i2s_toslink firmware to usbstreamer
* in win8.1, make usbstreamer the default audio device, disable enhancements, and set default format to 24/96
* connect ddrc-22d control to PC USB
* install ddrc-22 utility and control panel
* use ddrc-22 utility to upgrade firmware (although this was likely unnecessary)
* use dirac live calibration tool to play test tones and create a filter, and download the filter to ddrc-22d

I have checked everything on the win8.1 side and it looks correct.
Any suggestions for troubleshooting steps?
Or have I made some kind of bonehead mistake?

EDIT: I have tried basic troubleshooting steps...
...unplugging and replugging and verifying all connections are snug and correct
...power down everything and restart
...verified output level for usbstreamer is 100% in win8.1
...manually turned volume knob on ddrc22 clockwise many turns to max it out
...verified volume level on amplifier
Also should add that the LED indicators on both the usbstreamer b box and the ddrc-22d are on, with filter 1/spdifoptical/dirac live being the active LEDs on the ddrc22

Thanks
Last Edit: 2 months 2 weeks ago by CSAVELL.
The administrator has disabled public write access.

No audio win8.1 + usbstreamer b box + ddrc-22d 2 months 2 weeks ago #31462

  • CSAVELL
  • CSAVELL's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 1
  • Karma: 0
I got the microstreamer b box working by loading the "stereo" firmware version.
My understanding from reading the manual was that I should use the I2S_TOSLINK firmware, but I could not get it to work.
That "stereo" firmware file was included in the downloads, but is not mentioned in the manual...I found it just by browsing the firmware folder.
So at this point I am all setup and running successfully, and it sounds great. My Fostex full-rangers are no longer honking at me.
The administrator has disabled public write access.
The following user(s) said Thank You: devteam

No audio win8.1 + usbstreamer b box + ddrc-22d 2 months 1 week ago #31517

  • devteam
  • devteam's Avatar
  • Online
  • Administrator
  • Posts: 5648
  • Thank you received: 692
  • Karma: 130
@ CSAVELL

Great news to hear that you figured it out!
The USBStreamer is indeed a 10ch device by default. i.e. Toslink being ch9&10. IF you're doing direct streaming, it indeed needs the stereo firmware because WinOS doesn't always support to route audio directly to ch9&10. That's the issue here..

Anyway, glad to hear that you figured it out and are having fun with your setup! Enjoy!

Devteam
MiniDSP, building a DIY DSP community one board at a time.
Last Edit: 2 months 1 week ago by devteam.
The administrator has disabled public write access.
Time to create page: 0.103 seconds