Welcome, Guest
Username: Password: Remember me
NOTE: This forum is community powered. Please be mindful that long time community members are here to help as part of a community effort. If you have a specific issue (e.g. hardware, failure), please use our tech support portal (Support menu - > Contact Us). Thanks a lot of your help in making a better community. :-)

TOPIC: Static POP sounds

Static POP sounds 9 months 3 weeks ago #23658

  • JONTRE
  • JONTRE's Avatar
  • Offline
  • Junior Boarder
  • Posts: 21
  • Karma: 0
Hello,

I´ve just started up my new miniDSP DDRC-88A, almost emediately it started to coming poping sounds from the speakers. That sounded so bad that actually turned of directly again. The popping sounds coming every 20-30 seconds. Before I installed the unit I measured so that the polarity etc. is right in the contacts. Anyone know what might cause this?


EDIT: Running balanced connections for everything, but I tried with unbalanced for L,C,R only the rest is disconnected and suddenly I cant play the test sounds, a windows pops up and saying "Play Error: Play Stimulus Failed"

BR
JONTRE
Last Edit: 9 months 3 weeks ago by JONTRE.
The administrator has disabled public write access.

Static POP sounds 9 months 3 weeks ago #23659

  • rts100x5
  • rts100x5's Avatar
  • Offline
  • Senior Boarder
  • Posts: 70
  • Thank you received: 21
  • Karma: 0
Tell us more about how your unit is connected to your system...

Try a new USB cable ...shorter is better ... no longer than 5 ft
Last Edit: 9 months 3 weeks ago by rts100x5.
The administrator has disabled public write access.
The following user(s) said Thank You: JONTRE

Static POP sounds 9 months 2 weeks ago #23672

  • JONTRE
  • JONTRE's Avatar
  • Offline
  • Junior Boarder
  • Posts: 21
  • Karma: 0
rts100x5 wrote:
Tell us more about how your unit is connected to your system...

Try a new USB cable ...shorter is better ... no longer than 5 ft

I actually used a extension cable + original cable to connect to the minidsp. It seems like that was the problem. When connecting only with the short original cable I got no pops. :woohoo:
The administrator has disabled public write access.

Static POP sounds 9 months 2 weeks ago #23673

  • rts100x5
  • rts100x5's Avatar
  • Offline
  • Senior Boarder
  • Posts: 70
  • Thank you received: 21
  • Karma: 0
Yes I had the same issues with a NANO AVR DL un ti l I tried a short USB cable. I really dont understand the design incompatability... I have other devices that use 15ft + USB cables.....
The administrator has disabled public write access.
Time to create page: 0.097 seconds