Yes, all plug-ins are MAC OS x compatible. Have a look at the plug-ins datasheet for more information on the minimum systems requirements.